Members, Log In. Not a member? Sign Up

Ultimate Rollercoaster > Discussion Forums > Roller Coaster Games > RCT1 Help Needed

RCT1 Help Needed

Posted: 1/21/09 at 11:32:12 AM
Views: 20670

I have just purchased RCT1 for my laptop but when I play it won't load my saved games.
My laptop is Vista does this have anything to do with it?
Are there are ways I can get round this and get my saved games to load, I have tried going onto the saved games file and opening them with RCT.exe but this wouldn't work each.
Please help!
Many thanks.

Re: RCT1 Help Needed by phlydude at 2/13/09 4:24:02 PM

Goto the rct.exe file in Program Files>Hasbro Interactive>Roller Coaster Tycoon and right click on it. (It might be in the "American" folder - I can't quite remember)

Find the option that says compatibility
select the option for Win 98 and save

You will probably need to be an admin to do this (if you installed the program, you probably have the correct privileges)

Re: RCT1 Help Needed by mikelln at 3/9/09 8:57:05 PM

What if this still doesn't work? I've reinstalled everything. RCT1 works, but when I try to add the expansion pack of corkscrew follies/loopy landscapes, it doesn't work. and I get a "access violation- exception raised", error prompt. I DID get the game to work one time when i first did what you suggested... then it stopped working when i exited out tried to re-execute the game. I have vista, and i've tried everything... different compatability things.. such as trying to run it off 2000/95/98/etc. and trying to run it as administrator... nothing seems to work... and the original just isn't as good without the expansion packs haha... but any suggestions?

Re: RCT1 Help Needed by phlydude at 3/9/09 10:38:15 PM

Make sure you get all the updates - the loopy landscapes/corkscrew follies update allows it to work with Vista -
Uninstall them all
Install RCT1 and upgrade RCT to the latest version found here
and then install the LL/CF disk and upgrade that the latest version from here
(Scroll to the bottom and then select the loopy landscapes update for your country)

Set it to Win XP mode -

If you are trying to use a trainer, that could be giving you the error - you need to find the specific "drexler" patch made for XP

There is a whole walk through here - good luck

* This Post Has Been Modified *

Re: RCT1 Help Needed by mikelln at 3/10/09 8:12:38 PM

Dude, you are the MAN, that worked.
Thanks a lot, I really appreciate the help